Apr 21 2014 Not Affected By Heartbleed Flaw

On April 7, 2014, researchers disclosed a vulnerability in OpenSSL (a technology that powers encryption across much of the internet). The vulnerability is commonly known as the “OpenSSL Heartbleed Flaw”.

We would like to officially confirm that we do not use the affected versions of OpenSSL on servers. We have conducted all of the necessary investigations and determined that our data is not subject to any weakness.

Given the widespread nature of this issue, you may be wondering what you should do next. We recommend that you have a different password for each website you use, including as a matter of good practice we do recommend that you take some time to update all passwords.

You may change your password at any time using Settings >> Access tab of your account.

As always, please reach out to us if you have any questions.